[Résolu] plugin ultimateskyblock, les commandes ne fonctionne pas

Bonjour,

je viens de lancer mon projet skyblock et je suis bloquer des l’installation de plugin principal (uskyblock) une fois installer je tape la commande /is rien ne se passe.

actuellement j’ai comme plugin:
-EssentialsX 2.15.0.1
-Vault 1.6.7
-uskyblock 1.13
-multiverse core 2.6
-world edit 7.0.0
-world guard 7.0.0

et dans mes logs j’ai ce message:
[uSkyBlock] Enabling uSkyBlock v2.7.6-RC3
[13:14:33] [Server thread/ERROR]: Error occurred while enabling uSkyBlock v2.7.6-RC3 (Is it up to date?)
java.lang.NoClassDefFoundError: com/sk89q/worldedit/Vector
at us.talabrek.ultimateskyblock.Settings.loadPluginConfig(Settings.java:143) ~[?:?]
at us.talabrek.ultimateskyblock.uSkyBlock.reloadConfigs(uSkyBlock.java:988) ~[?:?]
at us.talabrek.ultimateskyblock.uSkyBlock.onEnable(uSkyBlock.java:222) ~[?:?]
at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:254) ~[spigot.jar:git-Spigot-a1f2566-a4c555b]
at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:339) [spigot.jar:git-Spigot-a1f2566-a4c555b]
at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:403) [spigot.jar:git-Spigot-a1f2566-a4c555b]
at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugin(CraftServer.java:434) [spigot.jar:git-Spigot-a1f2566-a4c555b]
at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugins(CraftServer.java:348) [spigot.jar:git-Spigot-a1f2566-a4c555b]
at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:214) [spigot.jar:git-Spigot-a1f2566-a4c555b]
at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:702) [spigot.jar:git-Spigot-a1f2566-a4c555b]
at java.lang.Thread.run(Unknown Source) [?:1.8.0_171]
Caused by: java.lang.ClassNotFoundException: com.sk89q.worldedit.Vector
at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_171]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:154) ~[spigot.jar:git-Spigot-a1f2566-a4c555b]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:100) ~[spigot.jar:git-Spigot-a1f2566-a4c555b]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_171]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_171]
… 11 more
[13:14:33] [Server thread/INFO]: **** Beginning UUID conversion, this may take A LONG time ****

Bonjour,

Ton plugin uSkyBlock v2.7.6-RC3 Ne s’active pas.

Vérifie la version ou change de plugins

1 « J'aime »

Meme problème même en changeant la version ou le plugin (essayer avec la 2.7.2 et le plugin askyblock)

Quelqu’un pourrait m’aider svp? =)

Bonjour,

Essayez d’installer les dernières versions de WorldEdit/WorldGuard disponibles ici :
http://builds.enginehub.org/job/worldedit?branch=master
http://builds.enginehub.org/job/worldguard?branch=master

1 « J'aime »
[15:29:46] [Server thread/ERROR]: Error occurred while enabling uSkyBlock v2.7.6-RC3 (Is it up to date?)
java.lang.NoClassDefFoundError: com/sk89q/worldedit/Vector
at us.talabrek.ultimateskyblock.Settings.loadPluginConfig(Settings.java:143) ~[?:?]
at us.talabrek.ultimateskyblock.uSkyBlock.reloadConfigs(uSkyBlock.java:988) ~[?:?]
at us.talabrek.ultimateskyblock.uSkyBlock.onEnable(uSkyBlock.java:222) ~[?:?]
at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:254) ~[spigot.jar:git-Bukkit-a4c555b]
at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:331) [spigot.jar:git-Bukkit-a4c555b]
at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:402) [spigot.jar:git-Bukkit-a4c555b]
at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugin(CraftServer.java:421) [spigot.jar:git-Bukkit-a4c555b]
at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugins(CraftServer.java:347) [spigot.jar:git-Bukkit-a4c555b]
at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:197) [spigot.jar:git-Bukkit-a4c555b]
at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:680) [spigot.jar:git-Bukkit-a4c555b]
at java.lang.Thread.run(Unknown Source) [?:1.8.0_191]
Caused by: java.lang.ClassNotFoundException: com.sk89q.worldedit.Vector
at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_191]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:130) ~[spigot.jar:git-Bukkit-a4c555b]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:76) ~[spigot.jar:git-Bukkit-a4c555b]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_191]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_191]
... 11 more

Je pense que le problème reste identique X)