Problème avec JSONAPI et pour lier mon site web


#1

Bonjour.
j’ai Installer JSONAPI protocallib et vault. (Pour la création d’un site avec comme CMS CraftMyWebSite)
Suite a cella j’ai réserver 3 port a la suite dans “gestion des ports” (30021;30022;30023)
J’ai modifier le fichier Config.yml avec le premier de mes ports réserver, dans mon cas ces le port 30021. sa donne sa:

API methods on the method-whitelist will be

able to called without any sort of authentication

method-whitelist:

  • getPlayerLimit
  • dynmap.getPort
    options:
    stream_pusher: {}
    use-new-api: false
    max_queue_age: 30
    max_queue_length: 500
    startup-delay: 2000
    port: 30021
    ip-whitelist: []
    log-to-console: false
    log-to-file: ‘false’
    anyone-can-use-calladmin: true
    use-new-api: false
    adminium-push-enabled: true

J’ai aussi modifier le fichier user.yml
ce qui donne:
users:

  • username: admin
    password: ***********
    logging: true
    groups:
  • full_control

Mais quand je démarre le serveur sa me dit que les ports 20059 20060 et 20061 sont utiliser sans être réserver.
J’ai chercher sur pas mal de site et les réponse sont sois vague sois ne corresponde pas a mon problème.
Merci de votre aide.
Cordialement.
ps: j’ai déjà contacter boxtoplay grâce a des tickets mais aucune réponse ne ma été fournie
depuis.


#2

Bonsoir,

Pour votre problème,

Sois votre plugin est pas a la bonne version

Sinon supprimé le fichier JSONapi et redémarré votre serveur et reconfiguré votre JSONapi car personnellement j’ai pas le même format du fichier Config.yml

Bonne chance


#3

Merci beaucoup de votre réponse je vais essayer. si cella ne fonctionne pas, vous avez une autre idée pour faire la liaison site/serveur même si il faut peux être changer de CMS.
cordialement.


#4

Si tu utilises Cmw, tu peux aussi essayer avec Rcon à la place de JSONAPI


#5

mais la liaison Rcon j’arrive pas a la faire.
je vais réessayer et si sa fonctionne pas serait t’il possible d’avoir une aide via skype ou discord.
Merci.


#6

Normalement j’ai tout bien configurer les fichiers, je vous laisser regarder par vous même.
(Config.yml)

API methods on the method-whitelist will be

able to called without any sort of authentication

method-whitelist:

  • getPlayerLimit
  • dynmap.getPort
    options:
    stream_pusher:
    max_queue_age: 30
    max_queue_length: 500
    startup-delay: 2000
    port: 30021
    ip-whitelist: []
    log-to-console: true
    log-to-file: ‘false’
    anyone-can-use-calladmin: true
    use-new-api: true
    adminium-push-enabled: true

(user.yml)

users:

  • username: lobe
    password: ******
    logging: true
    groups:
  • full_control

Je n’est pus le méssage qui dit que les ports 20059 20060 et 20061 sont utiliser sans avoir étais réserver et pourtant sur le site je n’arriver pas a faire la liaison, pouvez-vous m’aider (encore) désolé ^^’


#7

Bonjours,

Dans ton panel CraftMyWebite va dans: “réglage site”

Vérifie que L’ip/Port sois bon

Ensuite: “Réglage JsonAPI”

Vérifie bien le mot de passe et Ip du serveur

De fois une erreur d’inattention peut faire que sa ne se connecte pas

Si tout est bon redémarre ton serveur et dans: “Accueil et stats”

Tu devrais avoir sa: En Ligne/Status du Serveur

Bonne chance :slight_smile:


#8

Grace a vous j’ai vue que il y avait bien une erreur, mais maintenant je me retrouve avec un autre problème (qui est peux être extrêmement basique ) Donc sur le site on peux voir que le serveur et bien ouvert avec 999 personne max, quand je me connecte dessus il affiche bien (après 2 minute a peux prés) qu’il y a 1 joueur de connecter mais il est impossible d’aller dans l’onglet “chat” du site il me dit “Commencez par choisir le serveur ! :)” de plus les achats de la boutiques ne fonctionne pas. je pense que cella peux venir de la liaison JSONAPI.


image

je pense que sa peux vous aider a y voir plus clair.
Merci de votre aide.


#9

Salut,

Je te conseille d’arrêter de te prendre la tête, car la 2.0 de CMW va arriver bientôt, et ce ser ala refonte totale du CMS, donc s’en sera un nouveaux.
Au vu des problèmes, je te conseillerai dans la 2.0 d’utiliser RCON qui est plus simple.

Cordialement,


#10

Heyy,

Comme la dit @Sebastien3

La v2 devrais sortir très prochainement mais pour votre problème c’est très simple de le réglé.

Dans administration:

Réglages JSONAPI

ip du serveur >> Surprime le :25736

Sa doit donnée: 62.210.78.125

Et pour les “il affiche bien (après 2 minute a peux prés)”

C’est normal C’est le temps que JsonApi affiche le nombre de connectée

Voila bonne chance :slight_smile:


#11

Merci a tous pour votre aide et votre temps a m’aider, le problème est régler et cella grâce a votre aide et celle d’autre personne, encore merci.


#12

Pas de problème

Problème résolus je pense que on peut lock

Merci et a bientôt