Crash à répétition + Snapshot 18w50a


#1

Bonjour,

J’ai souscris à une offre serveur classique (2€99) sur votre site afin de pouvoir jouer à Minecraft avec un ami.
Depuis les premières heures, nous avons rencontré des soucis de crash à répétition, intervenant toutes les 30 minutes généralement. Nous n’avons pas trouvé d’élément déclencheur en jeu qui aurait pu être à l’origine de ces soucis.

Cela est très problématique, car le soucis implique que je sois toujours présent pour pouvoir redémarrer le serveur, étant le seul à avoir accès à mon espace client et donc à la commande de redémarrage.

Les logs n’affichent rien de particulier de ce côté, simplement un arrêt du serveur avec sauvegarde :

[01:46:49] [RCON Client #3/INFO]: [Rcon: Saved the game]
[01:46:49] [RCON Client #4/INFO]: [Rcon: Stopping the server]
[01:46:49] [Server thread/INFO]: Stopping server
[01:46:49] [Server thread/INFO]: Saving players
[01:46:49] [Server thread/INFO]: Nokaa lost connection: Server closed
[01:46:49] [Server thread/INFO]: Nokaa left the game
[01:46:49] [Server thread/INFO]: Saving worlds
[01:46:49] [Server thread/INFO]: Saving chunks for level 'world'/minecraft:overworld
[01:46:49] [Server thread/INFO]: ThreadedAnvilChunkStorage (world): All chunks are saved
[01:46:49] [Server thread/INFO]: Saving chunks for level 'world'/minecraft:the_nether
[01:46:49] [Server thread/INFO]: ThreadedAnvilChunkStorage (DIM-1): All chunks are saved
[01:46:49] [Server thread/INFO]: Saving chunks for level 'world'/minecraft:the_end
[01:46:49] [Server thread/INFO]: ThreadedAnvilChunkStorage (DIM1): All chunks are saved
[01:47:30] [RCON Client #5/INFO]: [Rcon: Saved the game]
[01:47:30] [RCON Client #6/INFO]: [Rcon: Stopping the server]

Un message d’erreur est néanmoins visible dans l’interface de l’espace client :

Votre serveur Minecraft #737 849 a un problème au niveau de la consommation mémoire. Celui-ci a besoin de plus de mémoire RAM pour pouvoir fonctionner.

J’ai déjà utilisé vos services il y a quelques temps de cela, nous arrivions à jouer sans soucis sur une offre à 1024 Mo à 4 joueurs. D’autant plus 1 Go semblerait tout de même une consommation excessive pour faire interagir deux joueurs avec un monde classique (en survie), je suppose donc que le soucis de consommation vient d’ailleurs.

Par ailleurs j’en profite pour poser une question : il me semble impossible de lancer le serveur sous la version 18w50a malgré sa proposition dans la liste des versions disponibles. En effet les erreur qui s’affichent alors dans la live console sont les suivantes :

```
[02:28:16] [main/FATAL]: Failed to start the minecraft serverjoptsimple.UnrecognizedOptionException: log-strip-color is not a recognized option	at joptsimple.OptionException.unrecognizedOption(OptionException.java:108) ~[Classic-v18w50a.jar:?]	at joptsimple.OptionParser.handleLongOptionToken(OptionParser.java:510) ~[Classic-v18w50a.jar:?]	at joptsimple.OptionParserState$2.handleArgument(OptionParserState.java:56) ~[Classic-v18w50a.jar:?]	at joptsimple.OptionParser.parse(OptionParser.java:396) ~[Classic-v18w50a.jar:?]	at net.minecraft.server.MinecraftServer.main(SourceFile:897) [Classic-v18w50a.jar:?]
```

J’ai essayé ce même .jar sur un instance locale, il fonctionne parfaitement. Le soucis ne vient donc pas du server.jar en lui-même.

Y a-t-il une solution pour résoudre les soucis de crash et éventuellement passer le serveur sous la dernière snapshot ?

Merci d’avance,

N.


#2

Bonjour !

Comme tu devrais le savoir, les snapshot sont des versions “Alpha” de la future version, qui est développement.

C’est pour cela qu’elle est instable(d’où tes crashs) et que je l’appelle Alpha et non Bétâ car les versions officielles comme la *1.13( et la 1.12 sont toujours en Bétà de mon point se vue vu tout les bugs…

Pour essayer de résoudre ton problème je ne peux te dire que d’attendre, car malheureusement rien ne peut le résoudre, tout vient de chez Mojang (Microsoft pardon, qui vont déclencher la mort du jeu comme avec tout leurs rachats uhm uhm), donc voilà, attends et tu pourras espèrer jouer :confused:

Ps : Je peux aussi t’assurer que ça ne vient pas de l’hébergeur car les logs sont clean, pas d’erreur, seulement le message d’arrêt de base.

Désolé !


#3

Je te remercie, malheureusement cette réponse est un peu hors-gonds à mon sens.

Encore une fois, comme expliqué dans mon thread, j’ai déployé une instance locale me permettant d’essayer le server jar 18w50a. Le serveur se lance correctement : j’en déduis que le soucis ne vient pas de la version proposée (étant identique en terme de poids sur les FTP, je l’assimile à celui téléchargeable sur le site officiel). J’ai pu de même essayé chez d’autres hébergeurs proposant des offres gratuites limités dans la durée, que je ne mentionnerai pas ici pour une raison évidente, qui semblent tolérer cet instance sans ces soucis évoqués.

Je ne comprends pas ce qui te permet de me certifier cela. Par ailleurs, avec un minimum de recul, on peut facilement attribuer l’erreur mentionnée à la configuration de log4j, d’où l’intolérance de l’option “–log-strip-color” du stater : c’est à l’hébergeur de revoir leur configuration. Cela n’inculpe pas Mojang, comme tu sembles le qualifier ici.

Enfin pour les crashs, je doute fort que la raison soit la version, car comme tu le dis toi-même, les logs sont cleans. La notification en revanche, indique une surconsommation des ressources : j’en reviens donc à me demander si les 1 Go sont encore suffisants aujourd’hui pour tolérer une instance Minecraft sous les versions actuelles. De mon côté et sur le serveur que j’ai pu exploiter, le processeur à nu (sans joueur) exploitait malheureusement dans les 1,4 Go.


#4

Salut,

Pour moi, les versions de minecraft sortent trop vite d’où les bugs qui sont présent mais bon, passons outre, (c’est mon point de vu :p)

Pour ce qui est de la RAM, si tu n’en n’as pas assez, tu reçois un mail d’avertissement sur ta boîte mail, alors essaye de check, ou il va falloir chercher la source de tes crashs.

Sinon, je ne saurai te conseiller de regarder l’onglet “Santé du serveur” et me dire, si il y a une erreur et si tu ne trouves rien, de passer par le support.

Cordialement,


#5

Salut.

Les snapshots de la 1.14 sont boguées. Il faut attendre.

Au fait @Sebastien3, je ne trouve pas la 1.12 boguée, m’enfin x)


#6

Pas autant, mais il y en a… ^^’


#7

Tu dois utiliser de mauvais plugins alors x)


#8

Nanananan je parle de la 1.12 sans plugin, sans artifices :slight_smile:


#9

La 1.12**.2** n’est pas boguée, je te conseille d’aller dessus. ^^’


#10

Bref, je suis déjà en 1.12.2 :stuck_out_tongue:

Auteur inactif, demande de lock


#11