Réglages SQL Iconomy

Bonjour à tous,

Voilà maintenant plusieurs jours (voir plus) que je me bat avec les réglages SQL de IConomy mais rien n’y fait ! Avec les autres plugins aucun problème, mes tables se créent sans soucis mais avec iconmy il me marques constamment que je suis en “flatfile” et j’ai beau essayer de plein de manières différentes il s’en fiche complétement ^^ Quelqu’un pour me sauver ?


Database:
# Databases Supported:
# Flatfile, FF, mini, minidb
# - These all equate to miniDB
##
# item, items, inventory, inventoryDB
# - These all equate to InventoryDB, which uses inventory for storage
##
# xp, exp, orb, xpdb, expdb, orbdb
# - These all equate to ExperienceDB, which relies on Experience for balance.
##
# mysql, mysqldb
# - These will attempt to connect to MySQL
##
# sqlite, sqlite2, sqlite3, sqlitedb
# - These will attempt to create & connect to SQLite
##
# postgre, postgreSQL, postgreDB
# - These will attempt to connect to PostgreSQL
Type: ‘mysql

# These are for InventoryDB only.
#
# InventoryDB is essentially Physical Money.
#   It isn't logged in a database, its based on the users inventory
#   and the two items selected below.
#
# MajorItem is the item or block ID of the major currency
# MinorItem is the item or block ID of the minor currency
# e.g. MajorItem: 266, MinorItem: 265 for Gold/Iron
MajorItem: 266
MinorItem: 265

# This controls the database name, by default it is iConomy
Table: 'iConomy'

# URL is for SQL Databases Only
##
# Path to iConomy folder is easy, it's the COMPLETE path.
# (Mine) G:\MineCraft\plugins\iConomy\
# Won't be the same as yours, but it usually looks like that.
##
# [H2DB Default] h2:path/to/iConomy/folder/iConomy;AUTO_RECONNECT=TRUE
# [SQLite Default] sqlite:path/to/iConomy/folder/iConomy.db
##
# Binary Databases use ip:port style connections.
# ip
#  - is the connection identifier (internet protocol)
#  - for ipv6 usually encased in brackets [::1]
# port
#  - the port that the database is listening on
#  - defaults: 3306 for mysql, postgre is either 5740 or 5432
##
# [MySQL Default] mysql://localhost:3306/iConomy
# [Postgre Default] postgresql://localhost:5740/iConomy
URL: '[b]mysql://localhost:3307/iConomy[/b]'  [i](déjà essayé avec localhost:3307)[/i]

# Login details for binary databases
Username: '[b]mon nom d'utilisateur bdd[/b]'
Password: '[b]mon MDP habituel[/b]'

##############################################################
# !!! Conversion is not your database settings !!!
##############################################################
# Conversion allows you to convert your old 5.x to the new 6.x
# All is currently unused.
##############################################################
# URL is for MySQL only, H2DB doesn't use it.
##############################################################
Conversion:
  # Set to True, After converting, change this back to false!
  Enabled: false

  # Database Type, H2DB or MySQL
  Type: '[b]MySQL[/b]'

  # Database Table
  Table: 'iConomy'

  # Database URL without table at the end.
  URL: 'mysql://localhost:3307/iConomy' [i](déjà essayé avec localhost:3307)[/i]

  # Username / Password
  # H2DB does not use this. MySQL Only.
Username: '[b]mon nom d'utilisateur bdd[/b]'
Password: '[b]mon MDP habituel[/b]'


  # Unused ATM.
  All: true

Oui j’ai bien rempli correctement les infos username et MDP je les utilisent sur d’autres plugins, le MDP est bien le premier mis à l’inscription etc etc …

Bref je perd la boule avec ce plugin !! :wink:

Merci d’avance à ceux qui ce donnerons la peine de répondre ^^

Iconomy est abandonné , je te conseille d’utiliser " BOSEconomy "

Cordialement

Merci pour ta réponse, mais ça ne répond pas à ma question xD

Il est abandonné et la liaison ne semble plus fonctionner donc je te conseille le plugin cité :wink:

Cordialement

Hugo petit question hors sujet depuis quand iconomy a été abondonne?

La dernière mise à jour d’Iconomy date d’Avril 02, 2012

Cordialement