Problème EnderPearl

Bonjour, Bonsoir,
J’ai ouvert un serveur minecraft récemment pour le Pvp/Fac.
Et quand un joueur ce connecte il est marqué qu’il n’a pas les accès pour utiliser les Ender-Pearl… Cela doit toucher le plugin Permissions or je ne vois rien lié aux ender pearl :c
Merci de m’aider ou me donner des conseils si vous avez déjà rencontré un problème de ce genre.

Cordialement, Chartan

Quelle est la liste de vos plugins ?

Je possède Essentials, AuthMe, AntiCheat , PermissionSBukkit, GroupManager , Faction/mcore, WorldGuard (je n’ai fait aucune config pour le moment mais j’ai fait le test d’autoriser les enderpearl dans une zone cela ne fonctionne toujours pas )
Ainsi que d’autres plugins mais qui ne relate pas des permissions ou quoi que ce soit.

Avec WorldGuard, autorisez les enderpearls grâce à la commande /region flag global enderpearl allow

Je vais faire le test et vous en dire des nouvelles.
Merci de vos réponses :slight_smile:
Cordialement Chartan
[hr]
Cela ne fonctionne toujours pas…
Quand je suis réduit au statut de joueur (deop + manuadd joueur)
Je ne peux absolument rien faire ! Ni jetter d’ender nul part ni manger de pomme cheat (je suppose que tout le reste ne fonctionne pas).
Un message affiche : "You are not permitted to use (l’item, exemple : ENDER_PEARL).
Seul les op ont les permisions.
Je ne comprends absolument pas d’oû cela peut provenir :c

Cela peut venir du config.yml d’Essentials, à la partie EssentialsAntiBuild. Quelle est le contenu de cette-dernière ?

Voici la totalité de la partie Essential Built du Plugin Essential, partie config.yml :

############################################################

±-----------------------------------------------------+

| EssentialsAntiBuild |

±-----------------------------------------------------+

############################################################

Disable various default physics and behaviors

For more information, visit http://wiki.ess3.net/wiki/AntiBuild

Should people with build: false in permissions be allowed to build?

Set true to disable building for those people.

Setting to false means EssentialsAntiBuild will never prevent you from building.

build: true

Should people with build: false in permissions be allowed to use items?

Set true to disable using for those people.

Setting to false means EssentialsAntiBuild will never prevent you from using items.

use: true

Should we tell people they are not allowed to build?

warn-on-build-disallow: true

For which block types would you like to be alerted?

You can find a list of IDs in plugins/Essentials/items.csv after loading Essentials for the first time.

10 = lava :: 11 = still lava :: 46 = TNT :: 327 = lava bucket

alert:
on-placement: 10,11,46,327
on-use: 327
on-break:

blacklist:

Which blocks should people be prevented from placing?

placement: 10,11,46,327

Which items should people be prevented from using?

usage: 327

Which blocks should people be prevented from breaking?

break:

Which blocks should not be pushed by pistons?

piston:

Which blocks should not be dispensed by dispensers

dispenser:

Alors cela vient du plugin Factions, assurez-vous d’avoir autorisé les enderpearls dans les territoires ennemis.

Comment puis-je accéder à ce plugin ?
Car nous ne pouvons pas directement toucher au pluggins et il n’y a pas de dossier pour la config :x .

Les fichiers de configurations du plugin Factions se trouve dans le dossier mstore à la racine de votre FTP.
Cette option se trouve dans /mstore/factions_mconf/instance.json.

A la ligne " “handleExploitEnderPearlClipping”: " changez la valeur par défaut.

Daccord la valeur par défaut était true, j’ai changé en false : “handleExploitEnderPearlClipping”: false,
Mais pour tous les items style : GODLEN_APPLE et d’autre c’est le même problème est ce que je dois faire tout l’inventaire et par la suite tout changer 1 par 1 ?
[hr]
RECTIFICATION !
Cela ne fonctionne toujours pas… Un joueur non op n’a aucune permissions… Ne peut pas jeter d’EnderPearl, ni manger ou autre :confused: !
Tout relate des permissions à mon avis

Si vous enlevez le .jar des plugins Factions et MCore, le problème persiste ?

Comment est ce que je peux enlever ce .jar ?
En le renommant ?

Ils se situent dans le dossier plugins à la racine de votre FTP, supprimez-les juste. Vos configurations seront gardées, il suffira juste de remettre les .jar .

Je ne comprends pas très bien :confused:
Je vais dans mon FTP --> Nom de mon dossier server --> Plugin – > ??
Et après cela ? Je supprime quel dossier exactement ?

Il faut que vous supprimiez les fichiers de Factions et MassiveCore en .jar .

Je pense avoir trouver la source ! Je n’ai pas les fichers que vous me citer ! Et les plugin que j’ai télécharger ne sont pas proposés sur l’hébergeur or je si je prends les vôtre j’aurais ces fichiers je vais donc essayer ainsi l’erreur devrait elle réglée :slight_smile: !
[hr]
Mon serveur est en 1.7.2 , le plugin Multiverse-Core ,CB 1.4.5 est t’il compatible ?
Et quel plugin faction 1.7.2 me conseillez vous ? :s
Il n’y a que le 1.7.9 et le 1.8.1 présent sur l’hébergeur
[hr]
J’ai tenté 2 plugins : Factions pour 1.7.2
et mcore 7.0.2
Je vais tout reload et refaire mes tests.
[hr]
J’ai réinstallé les 2 plugins mcore et Faction ! Et toujours ce message : "You are not permitted to use ENDER_PEARL.
Même message pour tout ce que je fais exemple : "You are not permitted to use GOLDEN_APPLE/ MONSTER_EGG/ …
Rhaaa ca m’énerve !!
Les non op n’ont pas de permissions…

Avez vous une autre idée ? Cela ne relaterais pas Plutot des permissions ? :x

Pouvez-vous nous fournir vos logs en intégralité ?

Vous voulez les logs de quels plugins exactement ?
Les plugins relatifs au pvp fac et permissions ?