Plugins

Bonjour,

J’ai mis à jour mon plugin Mcore en 1.7.4 pour pouvoir crée des factions mais ce plugin ne marche pas et meme en faisant Configuration plugin je n’ai pas accès aux dossiers.

PS: J’ai CraftBukkit 1.7.2.
J’ai le plugin Factions aussi.
D’autre plugins pour 1.7.4 marchent avec CraftBukkit 1.7.2.
[hr]
Désolé du double-post mais je viens de m’apercevoir quelque chose d’étrange…

Hier j’ai fait un The Towers et la map a été générée DANS l’ancienne map.
Depuis que je me suis téléporté aux coordonnées, le serveur a craché et aucun moyen de me connecter.

Merci d’avance, Chokela78

Pour Factions , quels sont les logs ?
Pour le problème de la map , je n’ai pas compris , peux tu réexpliquer stp ?

Cordialement

Désolé mais qu’est-ce qu’un log ?

Pour la map:
J’ai mis la map The Towers avec FileZilla en supprimant la map avec laquelle je jouait.
En réinstallant la map avec laquelle je jouait, en regardant le viewer HD la map the towers apparaissait.
je me suis téléporté au coordonnées et le serveur a crashé et depuis si je redémarre le serveur et que je me connecte dessus, il recrash à nouveau

Pour la map j’ai remise une ancienne et c’est bon

up…

Si tu peut dire t’es plugins pour gerer t’es mondes s’il te plaît pour voir le problème ! :slight_smile:

Alors mes plugins sont:
-Essentials CB 1.7.2-R0.3
-WorldEdit CB 1.7.2-R0.3, 1.7.4, 1.6.4
-RPG Items 2 CB 1.6.4-R2.0, 1.7.2, CB 1.6.4-R1.0
-Citizens 1.7.4
-Block Disguise CB 1.7.2-R0.3
-WorldGuard 1.7.4, 1.7.2, 1.6.4
-AuthMe Reloaded CB 1.7.2-R0.3
-Factions 1.7.4
-MCore 1.7.4
-Multiworld CB 1.7.2-R0.3

Même In-Games le plugin ne fonctionne pas O_o ? Car le plugin Faction quelque fois ne créer aucun fichier mais gere commeme le plugin :slight_smile:

Non en jeu il marche pas.

up =) =) =) =)

Peux tu nous montrer tes logs qui se trouvent dans l’onglet " Logs " ?

Cordialement

[12:21:14] [Server thread/INFO]: Starting minecraft server version 1.7.2
[12:21:14] [Server thread/INFO]: Loading properties
[12:21:14] [Server thread/INFO]: Default game type: SURVIVAL
[12:21:14] [Server thread/INFO]: Generating keypair
[12:21:14] [Server thread/INFO]: Starting Minecraft server on *:32038
[12:21:15] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks (MC: 1.7.2) (Implementing API version 1.7.2-R0.4-SNAPSHOT)
[12:21:15] [Thread-7/INFO]: ----- Bukkit Auto Updater -----
[12:21:15] [Thread-7/INFO]: It appears that you’re running a Development Build, when you’ve specified in bukkit.yml that you prefer to run Recommended Builds.
[12:21:15] [Thread-7/INFO]: If you would like to be kept informed about new Development Build releases, it is recommended that you change ‘preferred-channel’ in your bukkit.yml to ‘dev’.
[12:21:15] [Thread-7/INFO]: With that set, you will be told whenever a new version is available for download, so that you can always keep up to date and secure with the latest fixes.
[12:21:15] [Thread-7/INFO]: If you would like to disable this warning, simply set ‘suggest-channels’ to false in bukkit.yml.
[12:21:15] [Thread-7/INFO]: ----- ------------------- -----
[12:21:15] [Server thread/WARN]: Plugin RPG_Items v3.0.4' uses the space-character (0x20) in its nameRPG Items’ - this is discouraged
[12:21:15] [Server thread/ERROR]: Could not load ‘plugins/mcore.jar’ in folder ‘plugins’
org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: net/minecraft/server/v1_7_R2/PlayerInventory
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) ~[1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at org.bukkit.craftbukkit.v1_7_R1.CraftServer.loadPlugins(CraftServer.java:350) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at org.bukkit.craftbukkit.v1_7_R1.CraftServer.(CraftServer.java:312) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.PlayerList.(PlayerList.java:63) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.DedicatedPlayerList.(SourceFile:14) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.DedicatedServer.init(DedicatedServer.java:126) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.MinecraftServer.run(MinecraftServer.java:424) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.ThreadServerApplication.run(SourceFile:617) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
Caused by: java.lang.NoClassDefFoundError: net/minecraft/server/v1_7_R2/PlayerInventory
at com.massivecraft.mcore.MCore.getMCoreGsonBuilder(MCore.java:83) ~[?:?]
at com.massivecraft.mcore.MCore.(MCore.java:68) ~[?:?]
at java.lang.Class.forName0(Native Method) ~[?:1.7.0_40]
at java.lang.Class.forName(Class.java:270) ~[?:1.7.0_40]
at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:40) ~[1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
… 9 more
Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_7_R2.PlayerInventory
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:67) ~[1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) ~[1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.7.0_40]
at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.7.0_40]
at com.massivecraft.mcore.MCore.getMCoreGsonBuilder(MCore.java:83) ~[?:?]
at com.massivecraft.mcore.MCore.(MCore.java:68) ~[?:?]
at java.lang.Class.forName0(Native Method) ~[?:1.7.0_40]
at java.lang.Class.forName(Class.java:270) ~[?:1.7.0_40]
at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:40) ~[1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
… 9 more
[12:21:15] [Server thread/ERROR]: Could not load ‘plugins/Factions.jar’ in folder ‘plugins’
org.bukkit.plugin.UnknownDependencyException: mcore
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:216) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at org.bukkit.craftbukkit.v1_7_R1.CraftServer.loadPlugins(CraftServer.java:350) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at org.bukkit.craftbukkit.v1_7_R1.CraftServer.(CraftServer.java:312) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.PlayerList.(PlayerList.java:63) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.DedicatedPlayerList.(SourceFile:14) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.DedicatedServer.init(DedicatedServer.java:126) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.MinecraftServer.run(MinecraftServer.java:424) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
at net.minecraft.server.v1_7_R1.ThreadServerApplication.run(SourceFile:617) [1.7.2-R0.4-3023.jar:git-Bukkit-1.7.2-R0.3-2-g85f5776-b3023jnks]
[12:21:15] [Server thread/WARN]: While loading RPG_Items v3.0.4 (plugins/rpgitems2.jar) found old-data folder: plugins/RPG Items' next to the new oneplugins/RPG_Items’
[12:21:15] [Server thread/INFO]: [MultiWorld] Loading MultiWorld v5.1.1
[12:21:15] [Server thread/INFO]: [Citizens] Loading Citizens v2.0.12-SNAPSHOT (build 1114)
[12:21:15] [Server thread/INFO]: [WorldEdit] Loading WorldEdit v5.6.1
[12:21:15] [Server thread/INFO]: [BlockDisguise] Loading BlockDisguise v1.6
[12:21:15] [Server thread/INFO]: [CookieMonster] Loading CookieMonster v1.8
[12:21:16] [Server thread/INFO]: [WorldGuard] Loading WorldGuard v5.9
[12:21:16] [Server thread/INFO]: [Essentials] Loading Essentials v2.13.1
[12:21:16] [Server thread/INFO]: [RPG_Items] Loading RPG_Items v3.0.4
[12:21:16] [Server thread/INFO]: [EssentialsProtect] Loading EssentialsProtect v2.13.1
[12:21:16] [Server thread/INFO]: [EssentialsSpawn] Loading EssentialsSpawn v2.13.1
[12:21:16] [Server thread/INFO]: [EssentialsChat] Loading EssentialsChat v2.13.1
[12:21:16] [Server thread/INFO]: [EssentialsAntiBuild] Loading EssentialsAntiBuild v2.13.1
[12:21:16] [Server thread/INFO]: [AuthMe] Loading AuthMe v3.3.6
[12:21:16] [Server thread/WARN]: **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
[12:21:16] [Server thread/WARN]: The server will make no attempt to authenticate usernames. Beware.
[12:21:16] [Server thread/WARN]: While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
[12:21:16] [Server thread/WARN]: To change this, set “online-mode” to “true” in the server.properties file.
[12:21:16] [Server thread/INFO]: Preparing level “world”
[12:21:16] [Server thread/INFO]: Preparing start region for level 0 (Seed: 2272443067303537880)
[12:21:17] [Server thread/INFO]: Preparing start region for level 1 (Seed: 2272443067303537880)
[12:21:17] [Server thread/INFO]: Preparing start region for level 2 (Seed: 2272443067303537880)
[12:21:17] [Server thread/INFO]: [MultiWorld] Enabling MultiWorld v5.1.1
[12:21:17] [Server thread/INFO]: Preparing start region for level 3 (Seed: 1585771267264532206)
[12:21:18] [Server thread/INFO]: Preparing start region for level 4 (Seed: -6880531773901269931)
[12:21:19] [Server thread/INFO]: worlds.Arène_PvP
[12:21:19] [Server thread/INFO]: worlds.Salle_créateurs
[12:21:19] [Server thread/INFO]: worlds.world
[12:21:19] [Server thread/INFO]: worlds.world_nether
[12:21:19] [Server thread/INFO]: worlds.world_the_end
[12:21:19] [Server thread/INFO]: [MultiWorld] v5.1.1 enabled.
[12:21:19] [Server thread/INFO]: [Citizens] Enabling Citizens v2.0.12-SNAPSHOT (build 1114)
[12:21:19] [Server thread/ERROR]: [Citizens] v2.0.12-SNAPSHOT (build 1114) nest pas compatible avec Minecraft v{1}. Désactivation.
[12:21:19] [Server thread/INFO]: [Citizens] Disabling Citizens v2.0.12-SNAPSHOT (build 1114)
[12:21:19] [Server thread/INFO]: [WorldEdit] Enabling WorldEdit v5.6.1
[12:21:19] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.
[12:21:19] [Server thread/INFO]: [BlockDisguise] Enabling BlockDisguise v1.6
[12:21:19] [Server thread/INFO]: [CookieMonster] Enabling CookieMonster v1.8
[12:21:19] [Server thread/INFO]: [CookieMonster] Default setup file written: plugins/CookieMonster/config.yml
[12:21:19] [Server thread/INFO]: [CookieMonster] Using Essentials v2.2 for economy
[12:21:19] [Server thread/INFO]: [CookieMonster] v1.8 loaded successfully.
[12:21:19] [Server thread/INFO]: [CookieMonster] Developed by: [jascotty2, Coelho]
[12:21:19] [Server thread/INFO]: [WorldGuard] Enabling WorldGuard v5.9
[12:21:19] [Server thread/INFO]: [WorldGuard] (world) TNT ignition is PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (world) Lighters are PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (world) Lava fire is blocked.
[12:21:19] [Server thread/INFO]: [WorldGuard] (world) Fire spread is UNRESTRICTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] Loaded configuration for world ‘world’
[12:21:19] [Server thread/INFO]: [WorldGuard] (world_nether) TNT ignition is PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (world_nether) Lighters are PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (world_nether) Lava fire is blocked.
[12:21:19] [Server thread/INFO]: [WorldGuard] (world_nether) Fire spread is UNRESTRICTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] Loaded configuration for world ‘world_nether’
[12:21:19] [Server thread/INFO]: [WorldGuard] (world_the_end) TNT ignition is PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (world_the_end) Lighters are PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (world_the_end) Lava fire is blocked.
[12:21:19] [Server thread/INFO]: [WorldGuard] (world_the_end) Fire spread is UNRESTRICTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] Loaded configuration for world ‘world_the_end’
[12:21:19] [Server thread/INFO]: [WorldGuard] (Arène_PvP) TNT ignition is PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (Arène_PvP) Lighters are PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (Arène_PvP) Lava fire is blocked.
[12:21:19] [Server thread/INFO]: [WorldGuard] (Arène_PvP) Fire spread is UNRESTRICTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] Loaded configuration for world ‘Arène_PvP’
[12:21:19] [Server thread/INFO]: [WorldGuard] (Salle_créateurs) TNT ignition is PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (Salle_créateurs) Lighters are PERMITTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] (Salle_créateurs) Lava fire is blocked.
[12:21:19] [Server thread/INFO]: [WorldGuard] (Salle_créateurs) Fire spread is UNRESTRICTED.
[12:21:19] [Server thread/INFO]: [WorldGuard] Loaded configuration for world ‘Salle_créateurs’
[12:21:19] [Server thread/INFO]: [WorldGuard] 0 regions loaded for ‘world’
[12:21:19] [Server thread/INFO]: [WorldGuard] 0 regions loaded for ‘world_nether’
[12:21:19] [Server thread/INFO]: [WorldGuard] 0 regions loaded for ‘world_the_end’
[12:21:19] [Server thread/INFO]: [WorldGuard] 2 regions loaded for ‘Arène_PvP’
[12:21:19] [Server thread/INFO]: [WorldGuard] 1 regions loaded for ‘Salle_créateurs’
[12:21:19] [Server thread/INFO]: [Essentials] Enabling Essentials v2.13.1
[12:21:20] [Server thread/INFO]: Essentials: Using config file enhanced permissions.
[12:21:20] [Server thread/INFO]: Permissions listed in as player-commands will be given to all users.
[12:21:20] [Server thread/INFO]: [RPG_Items] Enabling RPG_Items v3.0.4
[12:21:20] [Server thread/INFO]: [RPG Items] World Guard found
[12:21:20] [Server thread/INFO]: [EssentialsProtect] Enabling EssentialsProtect v2.13.1
[12:21:20] [Server thread/INFO]: [EssentialsSpawn] Enabling EssentialsSpawn v2.13.1
[12:21:20] [Server thread/INFO]: [EssentialsChat] Enabling EssentialsChat v2.13.1
[12:21:20] [Server thread/INFO]: [EssentialsAntiBuild] Enabling EssentialsAntiBuild v2.13.1
[12:21:20] [Server thread/INFO]: [AuthMe] Enabling AuthMe v3.3.6
[12:21:20] [Server thread/INFO]: [AuthMe] Loading Configuration File…
[12:21:20] [Server thread/INFO]: [AuthMe] Set Language: en
[12:21:20] [Server thread/INFO]: [AuthMe] Hook with Essentials plugin
[12:21:20] [Server thread/INFO]: [AuthMe] Hook with EssentialsSpawn plugin
[12:21:20] [Server thread/INFO]: [AuthMe] LICENSE : This product includes GeoLite data created by MaxMind, available from http://www.maxmind.com
[12:21:20] [Server thread/INFO]: [AuthMe] Authme 3.3.6 enabled
[12:21:20] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
[12:21:21] [Server thread/INFO]: Done (4,941s)! For help, type “help” or “?”
[12:21:21] [Server thread/INFO]: Starting GS4 status listener
[12:21:21] [Server thread/INFO]: Starting remote control listener
[12:21:21] [Query Listener #1/INFO]: Query running on 0.0.0.0:32040
[12:21:21] [RCON Listener #2/INFO]: RCON running on 0.0.0.0:32039
[12:21:26] [Server thread/INFO]: Chokela78[/212.198.60.46:16841] logged in with entity id 602 at ([world] -190.21407069643496, 68.0, 37.549196425437984)

Mcore ne peut pas fonctionner donc Factions ne peut pas marcher :
[12:21:15] [Server thread/ERROR]: Could not load ‘plugins/mcore.jar’ in folder ‘plugins’

Cordialement

Merci beaucoup mais du coup, je peux faire quoi ??

Essayes de changer de version

Cordialement