Petite aide

[color=#0000CD]Salut tout le monde :slight_smile:

J’aimerai que chaque Joueurs en fonction de leur grade ;écrivent d’une couleurs
(ex tout les citoyens écrive en : Vers)
Merci d’avance[/color]
Cordialement
SkylCraft

Tu peux faire cela avec ton plugin de permission

Cordialement

D’accord , mais comment fait-on ?
Cordialement

Cela dépend de ton plugin de permission , quel plugin de permission utilises tu ?

Cordialement

Group Manager

Cordialement

Voici un exemple :
prefix: ‘&f[&4TonGrade&f] &4*’
Le * signifie la couleur que leurs messages auront dans le chat .

Cordialement

Sa ma fait perdre tout cette manipulation ! Mes grades n’apparaisse plus !

Cordialement

Peux tu me montrer ta configuration avant que ça ne bug ?

Cordialement

groups:
Default:
default: true
permissions:
- essentials.help
- essentials.helpop
- essentials.home
- essentials.list
- essentials.motd
- essentials.rules
- essentials.spawn
- essentials.afk
- essentials.eco
- essentials.back
- essentials.list
- essentials.kit
- essentials.kit.citoyens
- creativegates.use
- essentials.build
- multiverse.portal.access
- multiverse.portal.access.portailmines1
- multiverse.portal.access.portailmines2
- multiverse.portal.access.portailmines3
- multiverse.portal.access.portailmines4
- multiverse.portal.access.portailsemirp1
- multiverse.portal.access.portailsemirp2
- multiverse.portal.access.portailnth1
- multiverse.portal.access.portailnth2
- multiverse.portal.access.portailminage1
- multiverse.portal.access.portailminage2
- multiverse.portal.access.portailpvpwar1
- multiverse.portal.access.portailpvpwar2
- multiverse.portal.access.portailpvpwar3
- multiverse.portal.access.portailpvpwar4
- multiverse.portal.access.portailfun1
- multiverse.portal.access.portailfun2
- multiverse.portal.access.portailfun3
- multiverse.portal.access.portailfun4
inheritance:
- g:groupmanager_default
- g:bukkit_default
- g:essentials_default
- g:towny_default
info:
prefix: ‘&a[Citoyen]’
build: true
suffix: ‘&a &f’

Tient , peux tu me le faire pour ce groupe…
Merci d’avance
Cordialement

Bonjour SkylCraft,
J’allais sortir la config par défaut mais je ne l’ai pas trouvé… x)
Déjà enlève ce que tu as mis dans le suffix -> ‘&a &f’
Ensuite dans prefix tu mets & suivi d’un code couleur.
PS : Je te conseil de mettre un espace devant [Citoyen] afin d’éviter que le pseudo de la personne se retrouve collé avec son grade. :smiley:

Edit:

Pas nécessaire de mettre autant de code couleur ainsi que d’une étoile à la fin… :s
Juste un seul code couleur au début du prefix suffit… Enfin ma config de GroupManager est configurée comme ceci chez moi:

[quote] info:
prefix: '&fMembre ’
build: true
suffix: ‘’[/quote]
Et cela fonctionne. ._.

Je prenais exemple sur sa configuration et l’étoile signifiait ceci : Le * signifie la couleur que leurs messages auront dans le chat …

Cordialement

Euh pour le chat , oublie GroupManger , supprime le préfixe et installe Essentials chat .

Puis va dans le dossier Essentials puis ouvre le config.yml

Ligne 500 , tu verra ceci :

############################################################

±-----------------------------------------------------+

| EssentialsChat |

±-----------------------------------------------------+

############################################################

chat:

If EssentialsChat is installed, this will define how far a player’s voice travels, in blocks. Set to 0 to make all chat global.

Note that users with the “essentials.chat.spy” permission will hear everything, regardless of this setting.

Users with essentials.chat.shout can override this by prefixing text with an exclamation mark (!)

Users with essentials.chat.question can override this by prefixing text with a question mark (?)

You can add command costs for shout/question by adding chat-shout and chat-question to the command costs section."

radius: 0

Chat formatting can be done in two ways, you can either define a standard format for all chat.

Or you can give a group specific chat format, to give some extra variation.

If set to the default chat format which “should” be compatible with ichat.

For more information of chat formatting, check out the wiki: http://wiki.ess3.net/wiki/Chat_Formatting

format: ‘<{DISPLAYNAME}> {MESSAGE}’
#format: ‘&7[{GROUP}]&r {DISPLAYNAME}&7:&r {MESSAGE}’

group-formats:

Default: ‘{WORLDNAME} {DISPLAYNAME}&7:&r {MESSAGE}’

Admins: ‘{WORLDNAME} &c[{GROUP}]&r {DISPLAYNAME}&7:&c {MESSAGE}’

If you are using group formats make sure to remove the ‘#’ to allow the setting to be read.

Et la dedans tu vois ceci :

group-formats:

Default: ‘{WORLDNAME} {DISPLAYNAME}&7:&r {MESSAGE}’

Admins: ‘{WORLDNAME} &c[{GROUP}]&r {DISPLAYNAME}&7:&c {MESSAGE}’

Enleve le # devant default , Admin … et remplace default et Admin par le nom de tes groups si t’as plus de 2 grades , tu rerajoute 1 nouvelle ligne .

Et après tu fais tout tes modif et tu peut mettre ton pseudo , Préfixe , chat en des coleurs différent et faire un chat propre et si tu fais ça enleve le préfixe de GroupManager .

Quelques infos :
{WORLDNAME} = Dans le world où il est .
{GROUP} = le nom du group et non le fréfix
{DISPLAYNAME} = Pseudo
{FACTION} = faction ^^

et sur le net tu pourra en trouver d’autres pour qui servent à d’autres trucs …

J’espère que ça t’aura aidé :smiley: ( désolé pour mes fautes d’orthographe , j’y ai pas fait attention … )

salut moi aussi je n’y arrive pas et j’ai suivi ce que tu a dit crayzeur mais sa ne marche pas j’ai fait une erreur ?
group-formats:

Default: ‘{WORLDNAME} {DISPLAYNAME}&7:&r {MESSAGE}’

 owner: '{WORLDNAME} &c[{owner}]&4 {DISPLAYNAME}&7:&c {MESSAGE}'

donc le grade est owner

et que veut tu dire quand tu dit enleve le prefixe de groupmanager ?

Enlever le préfix c’est ça :
prefix: ‘&f[&4TonGrade&f] &4*’
en
prefix: ‘’

Puis essaie en mettant tous les grades que t’as mis sur group.yml de groupmanager , AVEC maj et autres …

salut je n’y arrive pas sa me dit qu’il y a un probleme mais je ne sais pas ou voila mon grade “owner”
essentials:
owner: ‘{WORLDNAME} &c[{owner}]&4 {DISPLAYNAME}&7:&c {MESSAGE}’
groupmanager
info:
prefix:’’
build: true
suffix: ‘’

mais dans ton group.yml du groupmanager t’as pas que owner comme group ? si t’as pas que owner essaie en mettant tous les grades .

j’en ai plein je suis cas meme pas obliger de tous les mettres si ?

je pense que si , j’ai encore jamais essayé de mettre qu’un seul grade .

d’accord mais sinon c’est bien comme sa qu’on fait ou j’ai fait une erreur ?
owner: ‘{WORLDNAME} &c[{owner}]&4 {DISPLAYNAME}&7:&c {MESSAGE}’
et on le met bien a la place de admin et de defaults