JsonAPI pour 1.8 ?

salut a tous,
je cherche depuis hier si JsonAPI est compatible en 1.8 car dès que je met le plugin (en version 1.8) aucun dossier ne s’affiche dans le dossier plugin … comment faire ?

Quels sont les logs ?

Cordialement

[19:29:34] [Server thread/INFO]: Starting minecraft server version 1.8
[19:29:34] [Server thread/INFO]: Loading properties
[19:29:34] [Server thread/INFO]: Default game type: SURVIVAL
[19:29:34] [Server thread/INFO]: Generating keypair
[19:29:34] [Server thread/INFO]: Starting Minecraft server on *:35350
[19:29:35] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-262c777 (MC: 1.8) (Implementing API version 1.8-R0.1-SNAPSHOT)
[19:29:35] [Server thread/ERROR]: Ambiguous plugin name AuthMe' for filesplugins/AuthMe-3.5-SNAPSHOT.jar’ and plugins/AuthMe.jar' inplugins’
[19:29:35] [Server thread/ERROR]: Could not load ‘plugins/DynmapPlotMe.jar’ in folder ‘plugins’
org.bukkit.plugin.UnknownDependencyException: dynmap
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:216) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:286) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.(CraftServer.java:248) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.PlayerList.(PlayerList.java:68) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.DedicatedPlayerList.(SourceFile:14) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:133) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:473) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at java.lang.Thread.run(Thread.java:745) [?:1.7.0_76]
[19:29:35] [Server thread/ERROR]: Could not load ‘plugins/JSONAPI-BLEEDING-mc1.8-R0.1-SNAPSHOT.jar’ in folder ‘plugins’
org.bukkit.plugin.UnknownDependencyException: Vault
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:216) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:286) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.(CraftServer.java:248) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.PlayerList.(PlayerList.java:68) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.DedicatedPlayerList.(SourceFile:14) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:133) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:473) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at java.lang.Thread.run(Thread.java:745) [?:1.7.0_76]
[19:29:35] [Server thread/INFO]: [AutoMessage] Loading AutoMessage v2.5.4
[19:29:35] [Server thread/INFO]: [GroupManager] Loading GroupManager v2.0.1
[19:29:35] [Server thread/INFO]: [WorldEdit] Loading WorldEdit v6.0;3342-78f975b9
[19:29:35] [Server thread/INFO]: [iConomy] Loading iConomy v7.0
[19:29:35] [Server thread/INFO]: [MassiveCore] Loading MassiveCore v2.7.5
[19:29:35] [Server thread/INFO]: [PlotMe] Loading PlotMe v0.16.3
[19:29:35] [Server thread/INFO]: [CookieMonster] Loading CookieMonster v1.8
[19:29:35] [Server thread/INFO]: [PlotMe-DefaultGenerator] Loading PlotMe-DefaultGenerator v0.16.1
[19:29:35] [Server thread/INFO]: [WorldGuard] Loading WorldGuard v5.9
[19:29:35] [Server thread/INFO]: [Essentials] Loading Essentials vTeamCity
[19:29:35] [Server thread/INFO]: [MagicCarpet] Loading MagicCarpet v2.4.5
[19:29:35] [Server thread/INFO]: [EssentialsSpawn] Loading EssentialsSpawn vTeamCity
[19:29:35] [Server thread/INFO]: [CreativeGates] Loading CreativeGates v2.7.5
[19:29:35] [Server thread/INFO]: [EssentialsChat] Loading EssentialsChat vTeamCity
[19:29:35] [Server thread/INFO]: [Factions] Loading Factions v1.8.2-U0.7
[19:29:35] [Server thread/INFO]: [AuthMe] Loading AuthMe v3.5-SNAPSHOT
[19:29:35] [Server thread/INFO]: [MassiveCore] Enabling MassiveCore v2.7.5
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] === ENABLE START ===
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §eLoading Cachefile datas…
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §eLoading Onlineplayer datas…
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §eLoading Registry datas…
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §eLoading Dbmojangapi datas…
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §bPlayer Strings Found: §d0
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §bPlayer Strings Cached: §d0
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §bPlayer Strings Remaining: §d0
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §eNow fetching the remaining players from Mojang API …
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §e … done!
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §eSaving Cachefile…
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] §eSetup of IdUtil took §d11§ems.
[19:29:35] [Server thread/INFO]: [MassiveCore 2.7.5] === ENABLE §aCOMPLETE §e(Took §d79ms§e) ===
[19:29:35] [Server thread/INFO]: [PlotMe] Enabling PlotMe v0.16.3
[19:29:35] [Server thread/INFO]: [PlotMe-DefaultGenerator] Enabling PlotMe-DefaultGenerator v0.16.1
[19:29:35] [Server thread/INFO]: [PlotMe-DefaultGenerator] PlotMe
[19:29:35] [Server thread/INFO]: [PlotMe-DefaultGenerator] PlotMe-DefaultGenerator
[19:29:35] [Server thread/INFO]: [PlotMe-DefaultGenerator] No old PlotMe configs to import.
[19:29:35] [Server thread/INFO]: Preparing level “world”
[19:29:35] [Server thread/INFO]: Preparing start region for level 0 (Seed: -1284159134091603281)
[19:29:36] [Server thread/INFO]: Preparing start region for level 1 (Seed: 8721395929365476667)
[19:29:36] [Server thread/INFO]: Preparing start region for level 2 (Seed: 8721395929365476667)
[19:29:37] [Server thread/INFO]: [AutoMessage] Enabling AutoMessage v2.5.4
[19:29:37] [Server thread/INFO]: [GroupManager] Enabling GroupManager v2.0.1
[19:29:37] [Server thread/INFO]: GroupManager - INFO - World Found: world
[19:29:37] [Server thread/INFO]: GroupManager - INFO - Superperms support enabled.
[19:29:37] [Server thread/INFO]: GroupManager - INFO - Scheduled Data Saving is set for every 10 minutes!
[19:29:37] [Server thread/INFO]: GroupManager - INFO - Backups will be retained for 24 hours!
[19:29:37] [Server thread/INFO]: GroupManager version 2.0.1 is enabled!
[19:29:37] [Server thread/INFO]: [WorldEdit] Enabling WorldEdit v6.0;3342-78f975b9
[19:29:37] [Server thread/INFO]: WEPIF: GroupManager detected! Using GroupManager for permissions.
[19:29:37] [Server thread/INFO]: [WorldEdit] Using com.sk89q.worldedit.bukkit.adapter.impl.Spigot_v1_8_R1 as the Bukkit adapter
[19:29:37] [Server thread/INFO]: [iConomy] Enabling iConomy v7.0
[19:29:37] [Server thread/INFO]: [iConomy - April Fools] Enabled (9 ms)
[19:29:37] [Server thread/INFO]: [iConomy] Hello, I’m Nijikokun. Yes, this is an April Fools joke, but ‘/money top’ was fixed! Enjoy :slight_smile: - Rare Version!
[19:29:37] [Thread-8/INFO]: [iConomy - April Fools] Purged accounts with default balance.
[19:29:37] [Server thread/INFO]: [CookieMonster] Enabling CookieMonster v1.8
[19:29:37] [Server thread/INFO]: [CookieMonster] Using iConomy v6 for economy
[19:29:37] [Server thread/INFO]: [CookieMonster] v1.8 loaded successfully.
[19:29:37] [Server thread/INFO]: [CookieMonster] Developed by: [jascotty2, Coelho]
[19:29:37] [Server thread/INFO]: [WorldGuard] Enabling WorldGuard v5.9
[19:29:37] [Server thread/INFO]: [WorldGuard] (world) TNT ignition is PERMITTED.
[19:29:37] [Server thread/INFO]: [WorldGuard] (world) Lighters are PERMITTED.
[19:29:37] [Server thread/INFO]: [WorldGuard] (world) Lava fire is blocked.
[19:29:37] [Server thread/INFO]: [WorldGuard] (world) Fire spread is UNRESTRICTED.
[19:29:37] [Server thread/INFO]: [WorldGuard] Loaded configuration for world ‘world’
[19:29:37] [Server thread/INFO]: [WorldGuard] (world_nether) TNT ignition is PERMITTED.
[19:29:37] [Server thread/INFO]: [WorldGuard] (world_nether) Lighters are PERMITTED.
[19:29:37] [Server thread/INFO]: [WorldGuard] (world_nether) Lava fire is blocked.
[19:29:37] [Server thread/INFO]: [WorldGuard] (world_nether) Fire spread is UNRESTRICTED.
[19:29:37] [Server thread/INFO]: [WorldGuard] Loaded configuration for world ‘world_nether’
[19:29:37] [Server thread/INFO]: [WorldGuard] (world_the_end) TNT ignition is PERMITTED.
[19:29:37] [Server thread/INFO]: [WorldGuard] (world_the_end) Lighters are PERMITTED.
[19:29:37] [Server thread/INFO]: [WorldGuard] (world_the_end) Lava fire is blocked.
[19:29:37] [Server thread/INFO]: [WorldGuard] (world_the_end) Fire spread is UNRESTRICTED.
[19:29:37] [Server thread/INFO]: [WorldGuard] Loaded configuration for world ‘world_the_end’
[19:29:37] [Server thread/INFO]: [WorldGuard] 1 regions loaded for ‘world’
[19:29:37] [Server thread/INFO]: [WorldGuard] 0 regions loaded for ‘world_nether’
[19:29:37] [Server thread/INFO]: [WorldGuard] 0 regions loaded for ‘world_the_end’
[19:29:37] [Server thread/INFO]: [Essentials] Enabling Essentials vTeamCity
[19:29:37] [Server thread/INFO]: Bukkit version format changed. Version not checked.
[19:29:37] [Server thread/INFO]: git-Bukkit-262c777 (MC: 1.8)
[19:29:37] [Server thread/INFO]: 1.8-R0.1-SNAPSHOT
[19:29:37] [Server thread/INFO]: Using locale en_US
[19:29:37] [Server thread/INFO]: Using locale en_US
[19:29:37] [Server thread/INFO]: Essentials: Using GroupManager based permissions.
[19:29:37] [Server thread/INFO]: [Essentials] Payment method found (iConomy version: 6)
[19:29:37] [Server thread/INFO]: [MagicCarpet] Enabling MagicCarpet v2.4.5
[19:29:37] [Server thread/INFO]: [MagicCarpet] Loading carpets…
[19:29:37] [Server thread/INFO]: [MagicCarpet] is now enabled!
[19:29:37] [Server thread/INFO]: [EssentialsSpawn] Enabling EssentialsSpawn vTeamCity
[19:29:37] [Server thread/INFO]: [CreativeGates] Enabling CreativeGates v2.7.5
[19:29:37] [Server thread/INFO]: [CreativeGates 2.7.5] === ENABLE START ===
[19:29:37] [Server thread/INFO]: [CreativeGates 2.7.5] === ENABLE COMPLETE (Took 24ms) ===
[19:29:37] [Server thread/INFO]: [EssentialsChat] Enabling EssentialsChat vTeamCity
[19:29:37] [Server thread/INFO]: [Factions] Enabling Factions v1.8.2-U0.7
[19:29:37] [Server thread/INFO]: [Factions v1.8.2-U0.7] === ENABLE START ===
[19:29:37] [Server thread/INFO]: [Factions v1.8.2-U0.7] Loading board from disk
[19:29:37] [Server thread/INFO]: [Factions v1.8.2-U0.7] Economy integration is disabled, and the plugin “Vault” is not installed.
[19:29:37] [Server thread/INFO]: [Factions v1.8.2-U0.7] === ENABLE DONE (Took 56ms) ===
[19:29:37] [Server thread/INFO]: [AuthMe] Enabling AuthMe v3.5-SNAPSHOT
[19:29:37] [Server thread/INFO]: [AuthMe] Loading Configuration File…
[19:29:37] [Server thread/INFO]: [AuthMe] Set Language: en
[19:29:37] [Server thread/INFO]: [AuthMe] Hook with Essentials plugin
[19:29:37] [Server thread/INFO]: [AuthMe] Hook with EssentialsSpawn plugin
[19:29:37] [Server thread/INFO]: [AuthMe] [LICENSE] This product includes GeoLite data created by MaxMind, available from http://www.maxmind.com
[19:29:37] [Server thread/INFO]: [AuthMe] [SPONSOR] AuthMe is sponsored and hook perfectly with server hosting VERYGAMES, rent your server for only 1.99$/months
[19:29:37] [Server thread/INFO]: [AuthMe] [SPONSOR] Look Minecraft and other offers on www.verygames.net !
[19:29:37] [Server thread/INFO]: [AuthMe] Authme 3.5-SNAPSHOT enabled
[19:29:37] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
[19:29:38] [Server thread/INFO]: Done (2.532s)! For help, type “help” or “?”
[19:29:38] [Server thread/INFO]: Starting GS4 status listener
[19:29:38] [Server thread/INFO]: Starting remote control listener
[19:29:38] [Query Listener #1/INFO]: Query running on 0.0.0.0:35352
[19:29:38] [RCON Listener #2/INFO]: RCON running on 0.0.0.0:35351
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Loading Cachefile datas…
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Loading Onlineplayer datas…
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Loading Registry datas…
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Loading Dbmojangapi datas…
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Player Strings Found: 0
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Player Strings Cached: 0
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Player Strings Remaining: 0
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Now fetching the remaining players from Mojang API …
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] … done!
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Saving Cachefile…
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] Upgrading from player name to player uuid…
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] … done!
[19:29:38] [Server thread/INFO]: [MassiveCore 2.7.5] (database saving will now commence which might lock the server for a while)
[19:29:38] [Server thread/INFO]: GroupManager - INFO - Bukkit Permissions Updated!
[19:29:39] [pool-3-thread-5/INFO]: [PlotMe] Checking if conversion to UUID needed…
[19:29:39] [pool-3-thread-5/INFO]: [PlotMe] No plot conversion needed

Voci l’erreur :

[19:29:35] [Server thread/ERROR]: Could not load ‘plugins/JSONAPI-BLEEDING-mc1.8-R0.1-SNAPSHOT.jar’ in folder ‘plugins’
org.bukkit.plugin.UnknownDependencyException: Vault
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:216) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:286) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.(CraftServer.java:248) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.PlayerList.(PlayerList.java:68) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.DedicatedPlayerList.(SourceFile:14) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:133) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:473) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]

Il faut installer sa dépendance “Vault”.
Et tu as également une deuxième erreur que je te conseille de corriger :

[19:29:35] [Server thread/ERROR]: Could not load ‘plugins/DynmapPlotMe.jar’ in folder ‘plugins’
org.bukkit.plugin.UnknownDependencyException: dynmap
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:216) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:286) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.(CraftServer.java:248) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.PlayerList.(PlayerList.java:68) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.DedicatedPlayerList.(SourceFile:14) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:133) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:473) [1.8-R0.1-SNAPSHOT.jar:git-Bukkit-262c777]
at java.lang.Thread.run(Thread.java:745) [?:1.7.0_76]

Il faut installer sa dépendance “Dynmap”.

Cordialement

merci beaucoup !
[hr]
Et quel est pour toi le meilleur cms pour un site d’un servuer pvp faction ? Lapis craft n’existe plus …

Malheureusement ceux que je vais te conseiller sont payants : CraftMyCMS, SamantCMS,…
Cependant regarde si WebCrafted ou ExtrazCMS te conviennent (CMS gratuits).

Cordialement

OUi j’ai fais ton tuto et quand je vais sur mon site ils me disent que je n’ai pas la permission (pour WebCrafted)

As tu bien uploadé le contenu du dossier WebCrafted à la racine de ton accès FTP ?

Cordialement

Oui oui mais par contre des que je redemarre ils me disent ca :
ATTENTION ! Il semblerait que les ports suivants soient utilisés par votre serveur sans avoir été réservés :
=> [8123]
Nous vous rappelons qu’il est strictement interdit d’utiliser un port sans l’avoir réservé depuis votre panel.
Cela est généralement dû à un nouveau plugin / mod que vous venez d’installer et que vous n’avez pas configuré.
Merci de vous rendre sur votre panel afin de réserver les ports puis de les assigner à vos plugins.
Faites bien attention à JSONAPI ! Ce plugin utilise 2 ports cachés en plus du port initial. Il vous faudra donc, pour utiliser JSONAPI, réserver 3 ports qui se suivent et assigner à celui-ci le 1er port. Par exemple, vous pouvez réserver 30000, 30001 et 30002 et assigner à JSONAPI le port 30000 de telle sorte que les ports cachés que JSONAPI utilisera (30001 & 30002) soient déjà réservés.
Si vous n’arrivez pas à solutionner le problème contactez-nous.

Cela vient de Dynmap, réserve un port et attribue le dans la configuration de Dynmap.

Cordialement

ok je vais essayer merci
Mais dans la config Dynmap on ne peut pas mettre de ports… enfie je ne l’ai pas trouvé
[hr]
Bon j’ai enlever le plugin Dynmap du coup mais je peut toujours pas comment faire ?

Le port que Dynmap réserve se trouve dans son configuration.txt à la ligne " webserver-port : ". Remplacez le port par défaut " 8123 " par le port que vous avez réservé depuis le panel.

Ca marche toujours pas …
cela me met:
Forbidden

You don’t have permission to access / on this server.

Où cette erreur s’affiche-t-elle ?