Forge ? Bukkit ? Cauldron ?

Hey les gens :slight_smile:
Je fais mon baptême avec ce premier poste. Pour la ptite histoire, l’arrivé de Pokemon Go m’a redonner l’envie d’y rejouer. Etant un adepte de minecraft, j’ai naturellement donc pensé à faire un server Pixelmon (moddé donc).
Dans mon engouement le plus totale, j’achete donc un serveur sur minecraft-mania (ou BoxtoPlay je sais pas lequel vous dite) pour 2 ans ! (les pepetes !! xD)
J’installe donc le forge en 1.8.9, le pixelmon en 1.8.9 (custom npc egalement en 1.8.9).
Je lance le serveur, niquel ! Je me connecte dessus, je peux jouer et capturer, c’est la fête !
Etant admin sur un autre serveur (sous bukkit et anciennement spigot), j’ai donc commencé à chercher à installer des plugins afin de rajouter du RP (style worldguard, economy, multiversportal etc).
Et la commence la desillusion…
“J’installe” les plugins, mais sur le serveur rien ne marche… Dans l’onglet “configurer les plugins” je ne les vois pas. Mince…
Alors je recherche sur internet et je vois qu’on ne peut pas installer de plugin sur un serveur Forge Oo. De la je tombe des nues, et j’entend parler d’un fameux serveur : Cauldron, qui serait une alternive combinant forge et bukkit afin d’avoir un serveur avec mod + pluggin.
Or je suis en 1.8.9 et j’apprend que Cauldron s’arrete à la 1.7.10 !! XD

Donc mes questions sont les suivantes :
Est-il vraiment impossible d’installer des plugins sur un serveur forge 1.8.9?
Y a t’il caché quelques part ou mes yeux sont pas allez, un Cauldron en 1.8.9
Doit-je me mettre en position foetal, pleurer les larmes de mon corp et installer Cauldron 1.7.10 et donc ne pas avoir la derniere versions de pixelmon … ?

Par avance merci à ce qui on lu et qui me répondrons ^^
Ciao

Bonsoir,

Malheureusement non, il n’est pas possible d’installer des plugins sur un serveur Forge 1.8.9
Tu peux cependant essayer de le faire sous SpongeForge : https://docs.spongepowered.org/master/en/server/management/plugins.html

Cordialement

Salut Hugo est merci de ta réponse,

Spongeforge est un mod à ajouter dans le dossier mod de mon serveur forge ? Ou c’est à remplacer completement mon serveur ? Enfaite j’arrive pas à savoir si SpongeForce est un openmod (comme craftbukkit, spigot, forge etc) ou un mod additionnelle pour permettre la compatibilité avec les plugins

Merci d’avance de ta réponse ou de celui que me repondra :slight_smile:

Non, c’est un autre mode de jeu donc il remplace complètement ton serveur (tu l’installes via l’openmod quoi :wink: ).

Cordialement

Ok ça roule je vais essayer ça !!
Vu qu’on me le propose pas dans la liste des openmods de suppose que je dois passer par le winscp ou fizilla pour l’installer direct, je tiens au courant de l’avancement :slight_smile:

Merci beaucoup

Bon… Après une après-midi est 50 tutos… toujours pas d’avancement.
Déjà au niveau de Sponge… Tu ma dis qu’il remplace complet mon serveur, a faire grace a l’open mod… donc ces ce que j’ai fait j’ai mid mon sponge dans mon serveur, je lai selectionné dans l’openmod, et…rien … le neant…
Je suis donc allez sur le wiki de sponge et ça me dit :

Lorsque vous êtes prêt à installer SpongeForge, vous pouvez procéder aux étapes suivantes:
Eteignez votre serveur Forge si il est allumé.
Téléchargez SpongeForge sur le site de Sponge et Forge sur MinecraftForge.
Placez SpongeForge.jar dans le dossier mods.
Démarrez le serveur et … amusez-vous !

C’est donc ce que j’ai fait. J’ai installer spongemod, pixelmon et customnpc dans le dossier mod, je lance mon serveur niquel. Ensuite sur le wiki il dise :

SpongeForge¶
Afin d’installer des plugins, placez-les dans le dossier “mods” de votre jeu ou le répertoire du serveur.

Même si cela ma parut curieux de mettre des plugins dans le dossier mod, c’est donc ce que j’ai fait, j’ai mid Worldedit dans le dossier de mod et lancer le serveur.

Et la viens le soucis, quand je fais la commence /sponge plugins, j’ai bien le pluggins Worldedit qui est listé (première victoire). Cependant, quand je fais la simplement commande : //wand (pour avoir la hache afin de faire des selections), cela me dit commande introuvable !. Mince … j’essaye : /worldedit://wand et la j’ai aucun message d’erreur et rien ne ce passe.

Bref je suis toujours au point mort… je ne trouve pas de tuto video qui montre comment installer sur un serveur dédié sponge, et qui montre comment ajouter des plugins ainsi que des mods …

Ha oui j’ai oublier de préciser un deuxieme point.

Qaund j’ajoute un plugin sponge, j’ai un .jar nommé legacyjavafixer-1.0 qui apparait. A ce que j’ai compris en lisant, ce fichier etait pour regler les problème de compatibilité de ce qui etait en 1.7, or je suis en 1.8.9 et j’ai beau le supprimé, il réparait a chaque redemarrage, qui fait par ailleur eteindre le serveur.
Voila pour le petit plus.

Je suis sur que plein de personnes comme moi essaye de faire des serveurs modé pixelmon en 1.8.9 tout en ayant des plugins comme worledit, worldguard pour les parcelle, admin shop etc, ça serait interressant de trouver une solution permettant cela et pourquoi pas en faire un tuto vidéo.
Je suis vraiment interressé par ce sujet :slight_smile:

Merci de votre réponse

Effectivement je me suis trompé dans l’installation de Forge.
As tu essayé avec cette version de WorldEdit : https://forums.spongepowered.org/t/worldedit-for-spongeapi/13361 ?
Par rapport au legacyjavafixer, c’est en effet étrange mais ça n’a aucune répercussion sur ton serveur, non ?

Cordialement

Salut Hugo,

Alors c’est exactement ce worldedit la que j’ai installer tout comme c’etait annoncé sur le wiki. Le serveur c’est lancé normalement mais malheureusement auncun moyen de faire un //wand, /worldedit://wand ou autre commande.

Ensuite le legacyjavafixer m’embete beaucoup car c’est lui qui empeche le serveur de ce demarrer :confused:

J’ai appris aujourd’hui que le dev de Pokeworld à réussi à faire uptdate sont serveur en gardant mod et pluging en 1.8.9 donc la solution existe belle est bien :confused: je tente de me renseigner c’est une TRES vieille connaissance

Bon, après quelques ptit renseignement qu’on m’a lacher … C’est bien avec Sponge qu’il à réussi à rendre compatible les mods et plugins…reste à savoir comment il a fait :confused: Pour l’instant je test et retest encore et encore et c’est toujours le même soucis…

Je n’ai pas trouvé dans les lignes de configuration de sponge une ligne permettant de bloquer legacy

Contacte nous depuis ton espace client par rapport au legacy java fixer.

Cordialement

Salut Hugo !

J’ai du nouveau ! J’ai installer forge 11.15.1.1890 avec spongeforge 4.2.0-BETA-1562
ainsi que mon mod pixelmon et… worldedit sponge ! C’est déjà un bon début !!

De plus pour l’instant le legacy n’est pas réapparu ce qui est une bonne nouvelle

Bonjour REDOX,

Je reviens sur ton topic qui est toujours d’actualité.

Sponge prend le principe de Cauldron MAIS ils ont leur propre API. Ce qui implique que les plugins de bukkit/spigot ne fonctionnent pas sous sponge !
Par contre tu as les équivalents pour Sponge (tu les verras dans le Ore sur le site de Sponge).

Tu pourras ainsi avoir pixelmon + des shops, des parcelles, … Le seul regret que j’ai de mon côté est que sous la V1.12.2, je ne trouve pas d’équivalent à worldedit. Du coup je suis en train de le coder maison.

J’espère t’avoir éclairé ! (Même si ca fait 2ans)

Bonjour,

Inutile de détérer des sujets merci !

Demande de lock :slight_smile:

1 « J'aime »